Cascade Issues

Incident Report for Grindr

Resolved

This issue is resolved. If you are still having issues, please force-close the app and try again. If you are still having issues, please visit http://help.grindr.com
Posted Aug 07, 2025 - 14:15 CDT

Investigating

We are currently investigating this issue.
Posted Aug 07, 2025 - 14:06 CDT
This incident affected: The Grid.