Reset password
Incident Report for Grindr
Resolved
This issue is resolved. If you are still having issues, please force-close the app and try again. If you are still having issues, please visit http://help.grindr.com
Posted Jul 25, 2024 - 21:00 CDT
Investigating
We are currently experiencing an issue with the password reset functionality. Users may not be able to complete the password reset process at this time.
Posted Jul 25, 2024 - 20:35 CDT