Woodwork Landing Page Unavailable

Incident Report for Grindr

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 22:31 CDT

Investigating

We are currently undergoing maintenance. Woodwork landing page is unavailable.
Posted Jul 22, 2026 - 14:43 CDT
This incident affected: Woodwork.